Back to overview
Resolved

DDOS

May 3, 2025 at 8:12pm UTC

Resolved
May 3, 2025 at 10:48pm UTC

Everything should be fine now, we upgraded our ddos protection

Updated
May 3, 2025 at 8:30pm UTC

Still continuing..

Updated
May 3, 2025 at 8:24pm UTC

We have managed to shut down this ddos

Created
May 3, 2025 at 8:12pm UTC

Huge DDOS